WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

Ответить


В целях предотвращения автоматической отправки форм спам-ботами, решите предлагаемое задание.
Смайлики
:D :) :( :o :shock: :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

BBCode ОТКЛЮЧЕН
Смайлики ВКЛЮЧЕНЫ

Обзор темы
   

Развернуть Обзор темы: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пт дек 02, 2016 9:24 pm

Попробуй это: viewtopic.php?p=49471#p49471
Это должно быть лучше, чем RemoteFX.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пт дек 02, 2016 9:18 pm

Сегодня добрался до офиса и еще раз помучал терминал. Вроде все работает. Даже Аеро видно. Смущает нестандартное отображение курсора в режиме "думаю". Он какого-то "желтушного" цвета. См. фото. При подключении mstsc - обычный голубоватый.
В настройках терминала graphic=abcdefg, bpp=32

?
Вложения
Курсор.jpg
Курсор.jpg (130.46 КБ) 13425 просмотров

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн ноя 21, 2016 6:01 pm

Так. С авторизацией разобрался. Удалил параметр User в конфиге - появилась возможность указать логин.
В ВМ залогинился. Система загрузилась. Работать можно.
Тормозит правда немного. Буду разбираться дальше.

Спасибо!

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн ноя 21, 2016 5:46 pm

А причем тут 2012r2, если я подключаюсь к Win7 corp?

Запрашивает только пароль. А логин берет из конфига терминала что ли?

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пн ноя 21, 2016 2:54 pm

iGOR_ писал(а):При загрузке запрашивает пароль. Первый раз такую картинку вижу.
Надо привыкать. На 2012R2 такое включено по умолчанию.
iGOR_ писал(а):При вводе пароля пользователя ВМ выдает ошибку. См. скрины. Лог во вложении.
Оно считает, что логин или пароль неправильные. Надо ввести правильные.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн ноя 21, 2016 1:27 pm

Скачал. Установил. Задал терминал версию 5.4.59. Включил в ВМ NLA.

При загрузке запрашивает пароль. Первый раз такую картинку вижу.
При вводе пароля пользователя ВМ выдает ошибку. См. скрины. Лог во вложении.
Вложения
Term1_WTware_00.1B.FC.E4.71.85_2016-11-21_13-25-15.txt.zip
(24.96 КБ) 114 скачиваний
Term1_foto_2016-11-21_2.jpg
Term1_foto_2016-11-21_2.jpg (35.16 КБ) 13510 просмотров
Term1_foto_2016-11-21_1.jpg
Term1_foto_2016-11-21_1.jpg (8.91 КБ) 13510 просмотров

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Вс ноя 20, 2016 1:05 pm

Спасибо! В Пн-Вт проверю и отпишусь.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Сб ноя 19, 2016 9:33 pm

1. Включи NLA:
Untitled.png
Untitled.png (193.89 КБ) 13527 просмотров
2. Попробуй это: http://pxe.ru/files/testing/201611192224.zip

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Ср ноя 16, 2016 5:41 pm

Добрый день! Поставил. Запустил. Кляпнул по иконке пользователя три раза - ноль эмоций, так же по иконке Другой пользователь.
Нажал эскейп - ноль эмоций.
Из положительных сдвигов - курсор стал выглядеть нормально (без черного контуре)
Лог во вложении.
Вложения
Term1_WTware_00.1B.FC.E4.71.85_2016-11-16_17-39-49.txt.zip
(36.39 КБ) 113 скачиваний

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Вт ноя 15, 2016 2:00 pm

Попробуй это:

http://pxe.ru/files/testing/201611151340.zip

Как можно меньше лишних действий! Ненужное движение мышью это тоже лишнее действие, оно сейчас будет писаться в лог.

Надо поставить. Запустить. Включить лог. Навести мышь на одну кнопку, нажать три раза. Навести мышь на вторую кнопку, ещё три раза нажать. Затем нажать Esc. Рассказать, среагировала ли она на Esc. Сохранить лог, выложить.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн ноя 14, 2016 4:38 pm

Нет. С самого начала клики не работают, в систему не зайти.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пн ноя 14, 2016 3:23 pm

Рамка вокруг некрасивая. Попробую поуже сделать.
Последнюю фразу не понял. Нажатие кнопки мыши не работает? А раньше, с квадратом, работало?

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн ноя 14, 2016 1:47 pm

aka писал(а):Вот это попробуй: http://pxe.ru/files/testing/201611120043.zip
Те же действия. Запустить, дойти до неправильного курсора, сохранить.
Запустил. Курсор теперь без черного квадрата. Сохранил. Потом попробовал "потыкать" - не работает.
Вложения
Term1_WTware_00.1B.FC.E4.71.85_2016-11-14_13-38-53.txt.zip
(28.44 КБ) 104 скачивания
Term_1_foto_new.jpg
Term_1_foto_new.jpg (86.57 КБ) 13583 просмотра

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

Rushmore » Вс ноя 13, 2016 7:30 pm

iGOR_ писал(а):На сколько я знаю, лизензия на клиентскую ОС все равно будет необходима. Плюс подписки, "разрешающие" использовать ее в виде ВМ.
Да, но поскольку вам также будет необходимо приобрести Software Assurance, то вы сможете в его рамках использовать любую версию ОС на ваше усмотрение и не упираться в Win7.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Вс ноя 13, 2016 2:58 pm

На сколько я знаю, лизензия на клиентскую ОС все равно будет необходима. Плюс подписки, "разрешающие" использовать ее в виде ВМ.
Но, наверное, это обсуждение уже для отдельной темы.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

Rushmore » Сб ноя 12, 2016 10:30 pm

iGOR_ писал(а):Снижение затрат на доп лицензирование. Уже есть лицензии на Win 7, но нет на более старшие версии Win.
Лицензии на клиентские ОС не дают права запускать их в виртуальном окружении, только на физическом железе. Читайте лицензионное соглашение. Лицензия для VDI стоит отдельных денег и в розницу не продается, плюс еще обязательно надо покупать Software Assurance. Так что ничего вы не сэкономите таким образом.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Сб ноя 12, 2016 9:52 pm

Спасибо. Но это уже в Пн.

P.S. Почему важен хост именно с клиентсой ОС, а не серверной:
1. Hyper-V в Win2008-2012 поддерживает "проброс" 3D адаптера RemoteFX только в клиенские ОС Win7-10 enterprise/ultimate - появляется шанс запустить на терминале CAD приложения в режиме 3D
2. Снижение затрат на доп лицензирование. Уже есть лицензии на Win 7, но нет на более старшие версии Win.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пт ноя 11, 2016 11:45 pm

Вот это попробуй: http://pxe.ru/files/testing/201611120043.zip
Те же действия. Запустить, дойти до неправильного курсора, сохранить.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пт ноя 11, 2016 1:33 pm

Проверил. Запустил - посмотрел на квадрат. Ничего не нажимал - сохранил. Лог во вложении. Действительно большой. Пришлось упаковывать.
Вложения
Term1_WTware_5.4.57_00.1B.FC.E4.71.85_2016-11-11_12-58-06.zip
(30.32 КБ) 105 скачиваний

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Чт ноя 10, 2016 11:00 am

Спасибо. В Пт проверю.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Чт ноя 10, 2016 1:38 am

Попробуй пожалуйста это:

http://pxe.ru/files/testing/201611100229.zip

Лог должен получиться большой. Как можно меньше лишних движений. Запустил, увидел квадрат, сразу сохранил.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Ср ноя 09, 2016 3:05 pm

Обновил версию на терминале с черным квадратом (term1). Проблема с подключением и квадрат остались...
Лог во вложении.
Вложения
Term_1_log_win_7_new_WTware_00.1B.FC.E4.71.85_2016-11-09_15-03-13.txt
(220.74 КБ) 834 скачивания

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Ср ноя 02, 2016 12:36 am

Лог чёрного квадрата со свежей втвари в студию.
iGOR_ писал(а):Есть все же подозрение, что сам протокол используемы WTWare "не дружит" с Win7.
Да, с семёркой мы RemoteFX не проверяли. RemoteFX писали, подключаясь напрямую к серверу, а не к виртуальной машине.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Вт ноя 01, 2016 6:18 pm

Собственно для этой машины и не нужно. Я пока только тестирую. Но настораживает то, что уже две машины не работают. Особенно странно ведет себя Term1 (черный квадрат и никакой реакции на нажатия).

Попробую еще развернуть ВМ с Win10 и поподключаться к ней.
Есть все же подозрение, что сам протокол используемы WTWare "не дружит" с Win7.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Вт ноя 01, 2016 6:08 pm

Гы. 1364. Значит я прав, win7 с remotefx (именно с remotefx, в обычной графике умеет) не умеет отдавать произвольные разрешения, поэтому майкрософты в клиенте убрали две точки, чтобы получить удобную (кратную 4) ширину экрана. Мониторы 1366х768 придумали враги и менеджеры по продажам.

Мне лень делать такой костыль для поддержки одного неудобного разрешения на старой системе со старой графикой. Напиши в конфиге конкретно этой машины "bpp=16" и она будет работать без RemoteFX.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Вт ноя 01, 2016 1:26 pm

Скрин подключения mstsc 1364x768
Term_2_log_Win2008r2_WTware_00.0C.76.6C.3A.A6_2016-11-01_13-03-40.txt - лог подключения терм2 к ВМ с Win2008r2 - работает без проблем
Term_2_log_win7_New_WTware_00.0C.76.6C.3A.A6_2016-11-01_13-25-04.txt - лог подключения к Win 7, новая версия ВТВаре - опять табличка про разрешение.
Вложения
Term_2_log_win7_New_WTware_00.0C.76.6C.3A.A6_2016-11-01_13-25-04.txt
(179.07 КБ) 829 скачиваний
Term_2_log_Win2008r2_WTware_00.0C.76.6C.3A.A6_2016-11-01_13-03-40.txt
(200.13 КБ) 878 скачиваний
mstsc_1364x768.jpg
mstsc_1364x768.jpg (138.75 КБ) 13726 просмотров

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Вт ноя 01, 2016 12:54 am

iGOR_ писал(а):У терм2 изначально в конфиге было прописано display=1366x768 При попытке подключиться к ВМ с такой настройкой получил ответ "Сервер требует установить разрешение 1288х768"
Поставил 1288х768 (в конфигураторе, через "ввести вручную") - один фиг, получил такое же сообщение...
Скриншот подключения mstsc к семёрке с remotefx в разрешении 1366x768 в студию.

И лог изначального подключения с 1366х768 тоже в студию.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн окт 31, 2016 11:12 pm

Нет. mstsc с разными работает.
У терм2 изначально в конфиге было прописано display=1366x768 При попытке подключиться к ВМ с такой настройкой получил ответ "Сервер требует установить разрешение 1288х768"
Поставил 1288х768 (в конфигураторе, через "ввести вручную") - один фиг, получил такое же сообщение...

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пн окт 31, 2016 11:03 pm

Что такое 1288x768 ?
mstsc.exe тоже работает с семёркой с remotefx в таком разрешении?

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн окт 31, 2016 10:24 pm

Был во втором сообщении. Дублирую.
Вложения
Term_2_log_WTware_00.0C.76.6C.3A.A6_2016-10-31_14-05-40.txt
(251.96 КБ) 841 скачивание

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пн окт 31, 2016 10:17 pm

Лог покажи.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн окт 31, 2016 9:51 pm

Скачал сегодня 5.4.52. Завтра попробую протестить.

Терминал 2 в моем тесте с лицензией - тоже ругается на разрешение.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

aka » Пн окт 31, 2016 9:44 pm

iGOR_ писал(а):Создана тестовая ВМ с Win 7 sp1 корп.
...
В чем может быть проблема?
В выделенном. Уже прошла восьмёрка и вышла десятка.

Ошибка с разрешением экрана лечится лицензией для втвари. Семёрка под RemoteFX умела делать только некоторые типичные разрешения, и когда втварь без лицензии отрезает кусок экрана под банер и просит не 1024х768, а необычное 960х768, семёрка с remotefx капризничает. Восьмёрка этим уже не должна страдать.

Ощибку с курсором никогда не видел. Если очень хочется подключиться к семёрке, покажи лог со свежей версией втвари.

Вот-вот выйдет втварь с новой графикой для 2012R2 и десятки. В ней и новый похожий на remotefx кодек, и арифметическое сжатие, и кэши. Будет заметно лучше, чем старый remotefx. Но я не знаю, умеет ли эту графику отдавать восьмёрка. Семёрка точно не умеет.

Re: WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн окт 31, 2016 2:16 pm

+ лог Term2 (в первом сообщении почему-то не дает больше 3х вложений)
Вложения
Term_2_log_WTware_00.0C.76.6C.3A.A6_2016-10-31_14-05-40.txt
(251.96 КБ) 875 скачиваний

WTWare 5.4.44+Hyper-V (2012R2)+RemoteFX+Win7 Corp SP1 - не работает :(

iGOR_ » Пн окт 31, 2016 2:12 pm

Добрый день!

Тестирую Remote FX.
Хост с 2012R2, подняты роли Hyper-V + RemoteFX
Создана тестовая ВМ с Win 7 sp1 корп.
Подключаюсь к ней mstsc - все ОК. RemoteFX работает, USB устройства пробрасываются.
Пробую подключится с терминала с WTWare 5.4.44 - вижу экран приветствия Windows. Указатель мыши с черным квадратом. Мышь перемешается, ни одна иконка не срабатывает. См. фото Term_1.
Пробую на другом терминале - выдает сообщение "Сервер требует установить разрешение 1288х768"
См. фото Term_2. Меняю разрешение, перезагружаю - тоже сообщение.
Пробовал еще на одной машинке в демо режиме. Там "Сервер требует установить разрешение 800х600". После установки и перезагрузки - требует 640-480....

К ВМ с Win 2008 R2 развернутой на этом же хосте с Hyper-V все эти терминалы подключаются без проблем.

Логи и фото экранов первых двух терминалов во вложении.

В чем может быть проблема?
Вложения
Term_1_log_WTware_00.1B.FC.E4.71.85_2016-10-31_13-45-03.txt
(219.02 КБ) 836 скачиваний
Term_2_foto.jpg
Term_2_foto.jpg (37.12 КБ) 13751 просмотр
Term_1_foto.jpg
Term_1_foto.jpg (69.94 КБ) 13751 просмотр

Вернуться к началу