Кодировка символов wtware 5.1 при запуске 1с.

Свойства, ошибки, замечания и проблемы определенных версий WTware
Ответить
Nik
Сообщения: 2
Зарегистрирован: Пн янв 20, 2014 8:34 am

Кодировка символов wtware 5.1 при запуске 1с.

Сообщение Nik » Пн янв 20, 2014 9:05 am

Вопрос вот в чем, на версии wtware 5.1.24 запускается 1с, в файле-конфиге через скрипт нужно прописать имя пользователя и пароль пользователя 1с, при запуске имя пользователя отображается некорректно (БСУ122). какую кодировку символов нужно использовать? в 4й wtware отлично работает, но в ней нет нужных драйверов видео.

Antonio
Сообщения: 208
Зарегистрирован: Пт фев 25, 2011 12:18 pm
Откуда: СПб

Re: Кодировка символов wtware 5.1 при запуске 1с.

Сообщение Antonio » Пн янв 20, 2014 11:32 am

UTF-16 пробовали?

aka
Разработчик
Разработчик
Сообщения: 10150
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Кодировка символов wtware 5.1 при запуске 1с.

Сообщение aka » Пн янв 20, 2014 1:14 pm

Конфиг сделай графическим конфигуратором. Конфигуратор сохраняет конфиги в кодировке UTF-16 little endian. Это двухбайтовая кодировка, каждый символ в файле занимает два байта. Только в этой кодировке работают русские и все остальные нелатинские буквы.

Никакая однобайтовая кодировка с русскими буквами работать не будет.

Nik
Сообщения: 2
Зарегистрирован: Пн янв 20, 2014 8:34 am

Re: Кодировка символов wtware 5.1 при запуске 1с.

Сообщение Nik » Пн янв 20, 2014 3:43 pm

UTF-16LE подошел, спасибо :) :) :)

Ответить