5.2.10 не видит невидимые SSID

Свойства, ошибки, замечания и проблемы определенных версий WTware
Ответить
Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

5.2.10 не видит невидимые SSID

Сообщение Azrael » Вс окт 05, 2014 1:17 pm

Пробная версия, которую вы мне скинули в соседней теме для тестирования, невидимые сети видела, а после обновления до 5.2.10 перестала.
И ещё вопрос, можно ли обновлять загрузочную флешку простым копированием файлов и папок из архива без виндовс утилит? Какие папки и файлы нужно копировать, если так можно делать?

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн окт 06, 2014 4:17 pm

Azrael писал(а):Пробная версия, которую вы мне скинули в соседней теме для тестирования, невидимые сети видела, а после обновления до 5.2.10 перестала.
У меня работает. Проверил только что. Делаю "поиск сетей", оно находит одну сеть с именем -hidden-, выбираю её, ввожу название как есть без hidden:, выбираю WPA/PSK, ввожу пароль - и оно у меня подключается. В настройках должно быть написано с hidden:, вот так:
Untitled.png
Untitled.png (7.56 КБ) 9641 просмотр
Azrael писал(а):И ещё вопрос, можно ли обновлять загрузочную флешку простым копированием файлов и папок из архива без виндовс утилит? Какие папки и файлы нужно копировать, если так можно делать?
Если мы не обновляли загрузчик (мы его уже много лет не обновляли), то всё должно получиться с копированием. Копировать каталог packages целиком.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн окт 06, 2014 5:46 pm

Спасибо, с копированием получилось...
Но скрытые сети все равно не видятся при поиске сетей.
Сегодня попробую поставить вручную hidden:

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн окт 06, 2014 6:08 pm

Скриншо только что сделал. 5.2.10 с сайта.
Untitled.png
Untitled.png (4.97 КБ) 9636 просмотров
Может сигнал слабый, или ещё какая не связанная со скрытостью проблема? Можешь на той же точке временно открыть SSID, ничего больше не меняя?

Сделай поиск сетей. В списке найденных сетей нажми Esc. Затем ещё раз Esc. Втварь попросит перегрузить терминал - опять жми Esc. Получишь командную строку. Из командной строки:

cat /tmp/all.log

Фотку экрана давай на aka@pxe.ru. Затем Shift-PageUp, ещё фотку, и так раз пять. Может в логе что-то инетресное будет. И без фоток долистай лог до верха, убедись, что на терминале загружена действительно 5.2.10.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Вс дек 14, 2014 10:22 am

По исходной теме - прописал в ручную и забыл ))
Далее при переходе на 5.2.14 глюк вроде не проявлялся. Специально для интереса проверял.
Но сейчас другая проблема возникла, тут без Вас точно ничего не получится.
Новая железяка - ноутбук Lenovo B590, с неведомой для wtware Wi-Fi картой.
Фотку экрана прикрепляю.
Вложения
Lenovo B590.jpg
Lenovo B590.jpg (235.43 КБ) 9482 просмотра

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Вс дек 14, 2014 3:08 pm

Наверно надо было об этой проблеме запостить сюда: http://forum.wtware.ru/viewtopic.php?f=10&t=19204
Прошу прощения за допущенную оплошность...

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн дек 15, 2014 5:11 am

Попробуй пожалуйста это: http://pxe.ru/files/testing/201412150508.zip

Драйвер новый, может не взлететь. Если не взлетит, то после ошибки оно вывалится в командную строку. Из командной строки надо запустить команду:
cat /tmp/all.log
Оно напишет много текста. Надо сфотографировать экран.
Затем нажать Shift-PageUp. Оно прокрутит вверх. Опять сфотографировать экран. И так еще пару раз.
Затем фотки мне на aka@pxe.ru

На боевую машину ставить осторожно, имея под рукой дистрибутив от 5.2.14 чтоб быстро переставить поверх, если что посыпется.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 11:13 am

не пошло.
И фотоаппарат не взял с собой. Может этот файл на загрузочную флешку с wtware как-то скопировать?

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн дек 15, 2014 12:09 pm

:( Нет, на флешку не получится.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 12:31 pm

Отправил на почту aka@pxe.ru

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн дек 15, 2014 4:59 pm

Упс. Опшибка вышла. Попробуй вот этот файлик на флешке заменить:

http://pxe.ru/files/testing/201412151658.zip

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 5:51 pm

Не работает...
Опять фоткать?

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн дек 15, 2014 6:02 pm

Да. Самый последний экран для начала, Shift-PageUp не нажимай.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 6:11 pm

Ушло.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 6:18 pm

Вообще надо как-то продумать вопрос, чтобы сочетанием кнопок или какой-то командой нужные для отладки логи копировались на флешку. Как думаешь? Типа набираешь в командной строке волшебное слово - и вуаля!

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 7:38 pm

гружу Ubuntu, чтобы подсказать тебе какой драйвер прикручивать.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 7:47 pm

Вот дела! Не видит Ubuntu этой карты Wi-Fi...

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Пн дек 15, 2014 8:43 pm

Судя по всему, в последний раз ты попытался подсунуть драйвер BCM4365
У меня в винде вот такая ифа по этой карте:
Строгое имя узла драйвера -
oem20.inf:bbe15847960d9523:BCM43XNG_NT62:6.30.59.26:pci\ven_14e4&dev_4365
Винда использует этот драйвер: bcmwl63a.sys

похожая проблема решена вот тут:
http://www.linuxspace.org/archives/4257

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пн дек 15, 2014 8:51 pm

Драйвер запустился, железку нашёл. Но почему он назвал интерфейс eth0? :evil:

Попробуй это:

http://pxe.ru/files/testing/201412152049.zip

Если не взлетит, попробуй из командной строки три буквы:

log

И Enter. Может, получится на флешку скинуть.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Вт дек 16, 2014 9:45 am

МЯУ !!!
Взлетело!
За идею слова из трех букв (я про "log", а не про то, что многие подумали) очередные ловцы багов в Wtware, не вооруженные фотоаппаратами, будут долго благодарить злого рыжего кота Азраэля.
Проверить, к сожалению (или к счастью), пока не удалось.
К сети невидимой я подключился, но вот в списке доступных сетей я ее не увидел. Дежавю?

PS:
Гаргамель и его офисные смурфики передают разработчику Wtware свои благодарности за достойный продукт!

PSPS:
Обнаружил еще, что разъемы USB 3 не работают... Есть возможность их поднять? Старых USB - всего две штуки. Использовать хаб совсем не хочется.

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Вт дек 16, 2014 11:28 pm

Невидимой сети нет в списке найденных (=видимых) сетей. Действительно, почему её там нет? ;)

Лог пришли после успешной загрузки и подключения к терминалке по WiFi.

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Ср дек 17, 2014 9:58 am

Да... Тормознул я!
Лог пришлю чуть позже, ноутбук оставил дома сегодня. Это для запуска USB 3 ?
Обратил внимание, что при загрузке, после ожидания нажатия del, полсекунды пару дополнительных строк просачивается на экран, по сравнению с предыдущими версиями.

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Чт дек 18, 2014 11:38 am

Поставь это поверх, а то в той сборке толстый глюк нашли: http://pxe.ru/files/testing/201412181119.zip

Лог хочу чтоб посмотреть, как себя чувствует драйвер wifi. Я этот драйвер в работе не видел никогда, у меня таких карт нет, надо же посмотреть, как оно. И про строки на экране, и про USB 3.0 без лога тоже ничего сказать не могу. Вообще-то сообщения о работе каких-то USB 3.0 контроллеров давным давно были. А разъемы сами живые? В биосе не отключены? Железка, которую подключаешь к USB, не боится USB 3.0?

Azrael
Сообщения: 34
Зарегистрирован: Пн июн 30, 2014 10:21 am

Re: 5.2.10 не видит невидимые SSID

Сообщение Azrael » Чт дек 18, 2014 1:07 pm

Сами разъемы USB 3 (синие) живые, в винде к ним удобные клава с мышой подключены и работают, а в Wtware - не хотят, даже на этапе редактирования конфигурации. Только старые USB черного цвета и работают.
В то же время, с синих USB, с которых иногда у многих и система-то не умеет грузиться, Wtware грузится, правда потом вылетает с ошибкой.
На команду "log" система ругается, что не может найти /bootmedia в /proc/mounts

В смысле "поставь это поверх"? Поверх в винде? Поставил 5.2.15 из 201412181119.zip на винду, форматнул им флешку, предварительно сохранив конфигурацию и восстановив потом ее обратно.
Там initrd уже правильный лежит, про старые твои правки и архивы можно забыть?

Полученный командой "log" файл all.log прикрепил (флешка была в черном USB 2 разъеме)

PS Нифига не прикрепил :lol: "Расширение log запрещено администратором." 8)
на мыло высылаю...

aka
Разработчик
Разработчик
Сообщения: 10124
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.2.10 не видит невидимые SSID

Сообщение aka » Пт дек 19, 2014 2:58 am

Про старые правки забыть, новая сборка жолжна быть лучше.

Лог говорит, что оно нашло две штуки xHCI Host Controller. Это USB 3.0. Ругани в логе не вижу. Дай лог побольше, с запуском, "disk=usb" в конфиге, подключением по WiFi к терминалке и втыканием флешки в USB 3.0. Пароль от WiFi можно вырезать, он там два раза в явном виде будет.

Ответить