Нет звука на терминале TC-S-M-845/256

Ответить
SANSoft

Нет звука на терминале TC-S-M-845/256

Сообщение SANSoft » Ср апр 28, 2010 7:57 am

Уважаемый aka!

Не могу победить проблему. Нет редиректа звука на терминал.
При подключении стандартным виндовым клиентом - звук есть. а в WTware PRO нету.

Версия: WTware PRO 4.5.6
Терминал: TC-S-M-845/256
в BIOS - поддержка звука включена. Колонки подключены в разьём, который на материнке.

настройки конфига терминалки:
include tc-s-m-845.wtc
resolution = 1280x1024
refresh = 60
graphic = a

содержимое tc-s-m-845.wtc:
usbdisk = on
sound = on
sound_level = 50
video = i915(F)

как настроить правильно? как увидеть что WTware-клиент опознал звуковуху?

aka
Разработчик
Разработчик
Сообщения: 9729
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Нет звука на терминале TC-S-M-845/256

Сообщение aka » Ср апр 28, 2010 10:42 am

SANSoft писал(а):При подключении стандартным виндовым клиентом - звук есть.
Стандартным виндовым клиентом подключаешься к тому же серверу и заходишь тем же юзером?
SANSoft писал(а):Версия: WTware PRO 4.5.6
4.5.46 наверное? Иначе - сначала качать свежую, потом думать.
SANSoft писал(а):в BIOS - поддержка звука включена. Колонки подключены в разьём, который на материнке.
Вот бы еще подключить к этой машинке винт, поставить виндовс и проверить, будет ли звук...
SANSoft писал(а):как настроить правильно? как увидеть что WTware-клиент опознал звуковуху?
Лог терминала делается так: http://wtware.ru/docs/config.html#syslog Пожалуйста, внимательно посмотри, что сохраняешь лог ТЕРМИНАЛА, а не службы TFTP. Лог присылается на aka@pxe.ru.

Гость

Re: Нет звука на терминале TC-S-M-845/256

Сообщение Гость » Ср апр 28, 2010 10:52 am

[quote]
Стандартным виндовым клиентом подключаешься к тому же серверу и заходишь тем же юзером?
[/quote]
Захожу на тот же сервер, с тем же логином

[quote]
4.5.46 наверное? Иначе - сначала качать свежую, потом думать.
[/quote]
Конечно 4.5.46! Опечатался

[quote]
Вот бы еще подключить к этой машинке винт, поставить виндовс и проверить, будет ли звук...
[/quote]
Попробую, если получится. Мне девайс на тест дали, вскрывать не хочется. Попробую на флешку поставить

[quote]
Лог терминала делается так: http://wtware.ru/docs/config.html#syslog Пожалуйста, внимательно посмотри, что сохраняешь лог ТЕРМИНАЛА, а не службы TFTP. Лог присылается на aka@pxe.ru.
[/quote]
Лог отправил. В теме пометил что от меня (SANSoft)

aka
Разработчик
Разработчик
Сообщения: 9729
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Нет звука на терминале TC-S-M-845/256

Сообщение aka » Ср апр 28, 2010 12:45 pm

Гость писал(а):Лог отправил. В теме пометил что от меня (SANSoft)
Прочитай сам этот лог. Там перемудрено с конфигами, и в результате параметр "sound=on" до терминала НЕ доходит.

Индивидуальные конфигурационные файлы терминала это:

| initrd: Download file "wtware.net\pro\4.5.46/configs/test-2.wtc" from TFTP server "192.168.2.250".
| initrd: Error code 1: File not found.
| initrd: Download file "wtware.net\pro\4.5.46/configs/00.E0.4C.77.25.69.wtc" from TFTP server "192.168.2.250".
| initrd: Error code 1: File not found.

Оба этих файла "File not found."

Ни в каком другом файле нельзя писать "include tc-s-m-845.wtc". include обрабатываются только в индивидуальном конфигурационном файле терминала.

Гость

Re: Нет звука на терминале TC-S-M-845/256

Сообщение Гость » Ср апр 28, 2010 2:01 pm

[quote="aka"][quote="Гость"]Лог отправил. В теме пометил что от меня (SANSoft)[/quote]
Прочитай сам этот лог. Там перемудрено с конфигами, и в результате параметр "sound=on" до терминала НЕ доходит.

Индивидуальные конфигурационные файлы терминала это:

| initrd: Download file "wtware.net\pro\4.5.46/configs/test-2.wtc" from TFTP server "192.168.2.250".
| initrd: Error code 1: File not found.
| initrd: Download file "wtware.net\pro\4.5.46/configs/00.E0.4C.77.25.69.wtc" from TFTP server "192.168.2.250".
| initrd: Error code 1: File not found.

Оба этих файла "File not found."

Ни в каком другом файле нельзя писать "include tc-s-m-845.wtc". include обрабатываются только в индивидуальном конфигурационном файле терминала.[/quote]

Ок. Попробую без премудростей.
На всякий случай покажу как сейчас настроено полностью (хотя делал все по мануалам и вроде работает. параметр syslog же подтянул):

файл list.wtс:
00.E0.4C.77.25.69(test-2) syslog.wtc # Для тестирования

файл sysog.wtc:
include tc-s-m-845.wtc
syslog = 192.168.2.250
resolution = 1280x1024
refresh = 60
graphic = a

файл all.wtc:
win2kIP = 192.168.2.249
codepage = win
turnoffmenu = always
keyboard = ru
managed = on
resolution = 1024x768
refresh = 85
bpp = 16
mouse_wheel = on

файл tc-s-m-845.wtc:
usbdisk = on
sound = on
sound_level = 50
video = i915(F)



Теперь попробую следовать рекомендации. Убиру "Include" и вставлю напрямую содержимое файла tc-s-m-845.wtc в файл sysog.wtc... если не получится, переименую затем файл sysog.wtc в файл test-2.wtc...
Отпишусь о результатах

Хотя так гибко было... Два терминала поодинаковому настроил. Только разрешения экрана разные в индивидуальных файлах были. Остальные терминалы работают через All.wtc и свои конфиги индивидуальные

Ответить