Связка двух микротиков и WTWare (загрузка из друой сети)

Методы загрузки терминала WTware - дискеты, старт из ДОС, загрузка по сети.
Ответить
azamat
Сообщения: 3
Зарегистрирован: Пт июн 08, 2018 2:50 pm

Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение azamat » Пт июн 08, 2018 3:50 pm

Добрый День.

Есть центр и филиал. В центре стоит микротик RB2011, в филиале стоит Mikrotik RB951Ui-2HnD.
Сервер стоит в центре. В филиале стоят будем устанавливать без дисковые станции на
текущий момент не получается осуществить загрузку.
По usb руководство не желает слышать загрузку.

Настройки DHCP

/ip dhcp-server option
add code=66 name=option66 value="s'192.168.1.111'
add code=67 name=option67 value="'5.4.90/wtware.pxe'"
/ip dhcp-server option sets
add name=bootserver options=option66
add name=Bootfilename options=option67
add name=pxes options=option66,option67
/ip pool
add name=dhcp ranges=192.168.3.100-192.168.3.199
add name=pool_guest ranges=172.16.1.100-172.16.1.200
/ip dhcp-server
add add-arp=yes address-pool=dhcp always-broadcast=yes dhcp-option-set=pxes \
disabled=no insert-queue-before=Local interface=bridge_local lease-time=\
1d name=server_local
add address=192.168.3.0/24 dhcp-option=option66,option67 dhcp-option-set=pxes \
dns-server=192.168.3.1,8.8.4.4 gateway=192.168.3.1

Настройки для FireWall:
/ip firewall filter
add action=accept chain=input comment="accept for guest dshp" dst-port=\
67,68,69 protocol=udp
add action=accept chain=output dst-port=69 out-interface=WAN1 port="" \
protocol=udp src-port=""
add action=accept chain=forward dst-port=67,68,69 protocol=udp
add action=accept chain=input dst-port=67,68,69 protocol=tcp
add action=accept chain=forward dst-port=67,68,69 protocol=tcp

При загрузке все необходимые данные для сетевой карты получает.
При загрузке выводит следующие данные:

PXE-T01: File not found.
PXE-E3B: TFTP Error - file not found.

И потом начинает грузить с жесткого диска.

webmatpoc
Сообщения: 8
Зарегистрирован: Чт фев 21, 2013 7:59 pm

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение webmatpoc » Пт июн 08, 2018 6:01 pm

вам не надо грузиться по tftp через туннель
tftp будет делать это вечность
файлы wtware надо положить на микрот в филиале
все файлы могут не влезть, уберите лишнее

все что нужно чтобы клиенты могли грузиться с микрота это
в DHCP указать next server(адрес самого микротика, без этой опции грузится 4.6.11 версия) и boot file name
и потрясающе простая настройка TFTP на микротике
кто то тут на форуме поделился этой информацией давно, золотой человек. до этого я все файлы перечислял отдельно
файлы кидайте в корень файловой системы для экономии времени

картинка вместо тысячи слов
Вложения
Wtware DHCP и TFTP.JPG
Wtware DHCP и TFTP.JPG (221.04 КБ) 456 просмотров

webmatpoc
Сообщения: 8
Зарегистрирован: Чт фев 21, 2013 7:59 pm

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение webmatpoc » Пт июн 08, 2018 6:06 pm

да. вот еще
по умолчанию tftp микротика работает только со статическими адресами
нужно или резервировать адреса или менять эту опцию
Вложения
DHCP.JPG
DHCP.JPG (69.91 КБ) 456 просмотров


aka
Разработчик
Разработчик
Сообщения: 9665
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение aka » Пт июн 08, 2018 8:10 pm

1. Загружаться с виндовса.
2. Настроить все, что нужно на терминале.
3. Посмотреть лог службы TFTP (в конфигураторе вверху слева кнопка с ключом, в списке "служба TFTP"). Те файлы, которые служба TFTP отдает и пишет об этом в лог - нужны. Те файлы, которые в логе не упоминаются - этому терминалу с этим конфигом не нужны.

azamat
Сообщения: 3
Зарегистрирован: Пт июн 08, 2018 2:50 pm

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение azamat » Сб июн 09, 2018 12:04 pm

С первичного tftp (он кстати может быть не только tftp, но и http) берётся:
- всё, что лежит в каталоге версии. Например: 5.4.62\wtware.pxe, 5.4.62\wtware.http.cfg, 5.4.62\packages\lib6
- Everyone/source.wtc
Я правильно понял, что он берет только те файлы которые лежат в корне каталоге 5.4.64\ - wtware.pxe, pxe.cfg, wtware.http, wtware.http.cfg,
wtware.nbi, bootx64.efi, http.efi И файл lib6 с каталога 5.4.64\packages. Если я в файле Everyone/source.wtc указал отличный сервер с которого будет скачиваться конфигурационные бинарные файлы, то остальные файлы мне не нужны ?

П.С. Вопрос связан из-за ограничения места в Микротике, размером 128 Mb.https://forum.wtware.ru/posting.php?mod ... =2&t=20503#

aka
Разработчик
Разработчик
Сообщения: 9665
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение aka » Сб июн 09, 2018 3:22 pm

azamat писал(а):
Сб июн 09, 2018 12:04 pm
Я правильно понял, что он берет только те файлы которые лежат в корне каталоге 5.4.64...
Да, конечно. А остальные файлы мы кладем в дистрибутив просто чтобы побольше и посолиднее выглядело.

Смотри лог TFTP (и HTTP, если загрузка переключается на HTTP). В логах будут файлы, которые нужны определенному терминалу с определенным конфигом. Другому терминалу или с другим конфигом могут понадобиться другие файлы. Не надо понимать. Надо посмотреть логи.

azamat
Сообщения: 3
Зарегистрирован: Пт июн 08, 2018 2:50 pm

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение azamat » Сб июн 09, 2018 4:45 pm

Да смотрел и увидел, что в основном это пять или шесть файлов используется. Хотя я постарался максимально взять настройки. И что за файлы это:
5.8.20/c8dc22a0-67d1-11df-a54f-9b3502537b09
5.8.20/01-00-26-2d-9b-a6-b8
5.8.220/C0A803C7
5.8.220/C0A803C
5.8.220/C0A803
5.8.220/C0A80
5.8.220/C0A8
5.8.220/C0A
5.8.220/C0
5.8.220/C
read filename:WTWare v5.8.20 at 00:26:2d:9b:a6:b8? dhcp = 192.168.x.x platform=x86, ip = ..., sign =
read filename:WTWare v5.8.20 at 00:26:2d:9b:a6:b8? dhcp = 192.168.x.x platform=x86, ip = ..., sign =

webmatpoc
Сообщения: 8
Зарегистрирован: Чт фев 21, 2013 7:59 pm

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение webmatpoc » Вс июн 10, 2018 12:12 pm

azamat писал(а):
Сб июн 09, 2018 4:45 pm

5.8.20/c8dc22a0-67d1-11df-a54f-9b3502537b09
5.8.20/01-00-26-2d-9b-a6-b8
5.8.220/C0A803C7
5.8.220/C0A803C
5.8.220/C0A803
5.8.220/C0A80
5.8.220/C0A8
5.8.220/C0A
5.8.220/C0
5.8.220/C
read filename:WTWare v5.8.20 at 00:26:2d:9b:a6:b8? dhcp = 192.168.x.x platform=x86, ip = ..., sign =
read filename:WTWare v5.8.20 at 00:26:2d:9b:a6:b8? dhcp = 192.168.x.x platform=x86, ip = ..., sign =
на эти записи в журнале внимание можно не обращать
главное положить на микрот файлы которые запрашивает клиент и которые при этом есть в дистрибутиве
в логе есть
5.8.220/C
но файла такого нет - пропускаем
в логе есть
"5.8.12\pxe.cfg"
и файл такой есть в каталоге с программой - закидываем его на микрот

структуру каталогов нарушать нельзя!

aka
Разработчик
Разработчик
Сообщения: 9665
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Связка двух микротиков и WTWare (загрузка из друой сети)

Сообщение aka » Вс июн 10, 2018 12:23 pm

azamat писал(а):
Сб июн 09, 2018 4:45 pm
И что за файлы это:
5.8.20/c8dc22a0-67d1-11df-a54f-9b3502537b09
5.8.20/01-00-26-2d-9b-a6-b8
5.8.220/C0A803C7
5.8.220/C0A803C
5.8.220/C0A803
5.8.220/C0A80
5.8.220/C0A8
5.8.220/C0A
5.8.220/C0
5.8.220/C
Варианты конфига pxelinux. Их нет в дистрибутиве втвари. Они не нужны.
azamat писал(а):
Сб июн 09, 2018 4:45 pm
read filename:WTWare v5.8.20 at 00:26:2d:9b:a6:b8? dhcp = 192.168.x.x platform=x86, ip = ..., sign =
read filename:WTWare v5.8.20 at 00:26:2d:9b:a6:b8? dhcp = 192.168.x.x platform=x86, ip = ..., sign =
Втварь рассказывает про себя втваревому TFTP серверу, чтоб терминал появился в списке конфигуратора. Это тоже не файл, он не нужен.

Ответить