Поиск Wi-Fi не работает (5.4.98)

Ethernet и WiFi. Прошивки, бутромы.
Ответить
Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Пн июл 10, 2017 1:38 pm

На жесткий диск ноутбука Lenovo V580c (model 20160) установил WTWare 5.4.98
Пытаюсь организовать подключение через Wi-Fi (с удовольствием бы через кабель сделал, но нужен Wi-Fi).
Включаю ноут, захожу в меню WTWare (нажал Del).
Первый пункт: Сеть - выбрал WiFi Wireless
Второй пункт красным: Настройка WiFi
Перешел туда, прописал SSID, Security, Key.
Нажимаю "Запустить драйвер WiFi".
Дальше появляется на том же месте пункт "Поиск WiFi сетей", нажимаю.
И потом вываливается ядреная ругань:
2017-07-10 13.10.53.jpg
2017-07-10 13.10.53.jpg (153.76 КБ) 895 просмотров
2017-07-10 13.11.07.jpg
2017-07-10 13.11.07.jpg (159.21 КБ) 895 просмотров
2017-07-10 13.11.18.jpg
2017-07-10 13.11.18.jpg (146 КБ) 895 просмотров
Если просто обычный Ethernet подключаю, то все в порядке, ноут работает. При загрузке с линукcа с Live образа, Wi-Fi работает.
Можно ли исправить это? Что для этого нужно?

aka
Разработчик
Разработчик
Сообщения: 9122
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение aka » Пн июл 10, 2017 3:59 pm

Shaaarnir писал(а):Что для этого нужно?
Лог после загрузки с езернетом.

И вот такое запусти из конмандной строки линукса с Live образа:

dmesg > /tmp/1.txt

И добудь файл /tmp/1.txt

Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Пн июл 10, 2017 5:27 pm

Сделал.
Во вложении лог после загрузки с езернетом и dmesg.
Вложения
WTware_3C.97.0E.3E.2C.26_2017-07-10_17-08-47.txt
Ethernet
(227.22 КБ) 10 скачиваний
1.txt
dmesg
(52.59 КБ) 11 скачиваний

Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Вт июл 11, 2017 5:33 pm

Если что еще нужно, то готов сделать.
Два одинаковых ноутбука Lenovo V580c выдали, и оба должны быть мобильными.

aka
Разработчик
Разработчик
Сообщения: 9122
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение aka » Сб июл 15, 2017 2:05 pm


Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Пн июл 17, 2017 12:20 pm

В версии 5.6.11 ошибка появляется после нажатия на пункт меню "Запустить драйвер WiFi"
2017-07-17 11.46.32.jpg
2017-07-17 11.46.32.jpg (107.7 КБ) 797 просмотров
Ниже выложу cat /tmp/all.log

Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Пн июл 17, 2017 12:45 pm

Первые три экрана cat /tmp/log
2017-07-17 12.28.28.jpg
2017-07-17 12.28.28.jpg (144.33 КБ) 797 просмотров
2017-07-17 12.29.34.jpg
2017-07-17 12.29.34.jpg (168.79 КБ) 797 просмотров
2017-07-17 12.31.43.jpg
2017-07-17 12.31.43.jpg (158.19 КБ) 797 просмотров
Если нужны будут остальные, то могу выложить все.

aka
Разработчик
Разработчик
Сообщения: 9122
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение aka » Ср июл 19, 2017 10:30 am

Упс :(

А вот это попробуй:

http://pxe.ru/files/testing/201707191128.zip

Здесь в самом конце: https://wtware.ru/logs.html написано про команду log. Попробуй её, если она сработает - на флешке будет полный лог, и фотографии не придётся выкладывать.

Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Ср июл 19, 2017 12:01 pm

Все работает :)
Огромнейшее преогромнейшее спасибо!

PS за log запомнил, в будущем так буду делать

Аватара пользователя
Shaaarnir
Сообщения: 359
Зарегистрирован: Ср дек 24, 2008 2:55 pm
Откуда: Украина, Харьков
Контактная информация:

Re: Поиск Wi-Fi не работает (5.4.98)

Сообщение Shaaarnir » Ср июл 19, 2017 3:46 pm

Посмотрел скрипт log. Там есть недоработка на мой взгляд.
В случае, если используется жесткий диск на терминале, то примаунтить флешку не выйдет.
Скрипт пытается только монтировать /dev/sda и /dev/sda1
А подключенная флешка уже будет /dev/sdb1
Может прописать попытки монтирования хотя бы до sdc ? (/dev/sdc, /dev/sdc1, /dev/sdb, /dev/sdb1, /dev/sda, /dev/sda1)
Ради интереса прописал в конец скрипта следующую строку и тогда команда log выполнилась и скопировался лог:
echo "mount /dev/sdb1 /bootmedia && cp /tmp/all.log /bootmedia/" >> /bin/log

Ответить