6.0.34-6.0.42 - аппаратное ускорение h264 на Raspberry и Intel

Свойства, ошибки, замечания и проблемы определенных версий WTware
Ответить
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

6.0.34-6.0.42 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение aka »

Аппаратное ускорение h264 AVC444.

В 6.0.34 появилось на Raspberry. На Raspberry можно сомтреть видео по RDP! Ничего похожего раньше не было. WTware единственный RDP клиент, который умеет показывать годное видео на Raspberry по RDP с аппаратным h264.

В 6.0.38 появилось на x86 и UEFI. Для чипов Intel должно работать аппаратное ускорение, для AMD будет позже, но уже сейчас заработает программное, которое тоже вполне шустро.

В 6.0.42 заработало определение пропускной способности сети ("bandwidthautodetect:i:1" в .rdp файле). Если сеть позволяет, сервер отдаёт больше трафика (видел до 30 мегабит на клиента), и качество картинки в некоторых сценах заметно улучшается.

Кодек создает заметную нагрузку на процессоры сервера (до 30% на всех шести ядрах Core i5 для одного клиента при просмотре FullHD видео). Если все ядра сервера перегружены, видео может искажаться. Аппаратное ускорение на сервере работает, если сервер работает на физическом железе. В последних HyperV Майкрософт прекратила поддержку RemoteFX 3D Video Adapter, аппаратное ускорение в виртуальных серверах теперь под вопросом...

В WTware по умолчанию включено. Если будет неправильно рисовать, отключить строкой "graphic=disable-h264" в конфиге терминала.

На серверах по умолчанию отключено. Надо включать руками, в gpedit.msc здесь:
h264_1.png
h264_1.png (54.77 КБ) 11494 просмотра

Сжимается вся графика одинаковым кодеком, не только видео. Поэтому видео идёт значительно лучше, а с деловой графикой могут случаться сюрпризы. Картинка-тест для h246:
h264_crash_test_800.png
h264_crash_test_800.png (7.51 КБ) 8850 просмотров
Картинку надо скачать и открыть в штатном MS Paint. Не приближать, только 100% зум. Если в RDP сессии используется сжатие h264, то и на втвари, и в mstsc.exe появятся спецэффекты. Лучше всего оно выглядит на 2019 сервере без аппаратного ускорения видео на сервере. В 2019 без аппаратного ускорения видео на сервере широко распиареный AVC444 просто отключен, работает AVC420, под AVC420 эту картинку заметно размоет. На 2016 сервере и на 2019 с аппаратным ускорением видео будет работать AVC444, и он будет работать меееедленно. Можно успеть рассмотреть, чем AVC420 (быстро, но размоет эту картинку) отличается от AVC444 (меееедленно, но восстановит всё, что испортил AVC420).
Dim-soft
Сообщения: 490
Зарегистрирован: Пт янв 13, 2006 9:57 am

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Dim-soft »

а какие плюсы ?
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Графика быстрее рисуется. Видео плавнее. Я минусов по сравнению с нынешним кодеком не вижу.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Как по логу понять, что оно работает?
Можно ли удалённо сравнить производительность, нагрузку на CPU, GPU?
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

В логе такая строка означает, что втварь предлагает серверу работать по h264:

Код: Выделить всё

Advertice h264 AVC444.
Если этой строки нет, значит что-то не нравится втвари (старая версия, не малина, bpp=16).

Если сервер соглашается работать по h264, то в логе появится:

Код: Выделить всё

[MMAL] Init h264 decoder for 1312x768 stream.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Значит работает. Супер.
Можно во время работы узнать fps?
Вложения
2021-02-11_11-43-58.png
2021-02-11_11-43-58.png (4.81 КБ) 11437 просмотров
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Оно тебе надо расстраиваться? Работает и ладно. Да и фреймы там есть только в редких случаях, когда обновляется полностью весь экран, чаще оно обновляет кусочками.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

А вот и первые ласточки.
Четвёртая малина с двумя мониторами.
После обновления вылезла ошибка "Недостаточно памяти, напишите gpu_mem=128".
Написал, перегрузил.
Теперь ошибка "TCP/IP connection lost. Network failure?"
При этом я подключаюсь к терминалу и в браузере и по VNC.
Вложения
WTware v.6.0.34_RPi.html
(63.33 КБ) 122 скачивания
2021-02-11_14-35-22.png
2021-02-11_14-35-22.png (7.23 КБ) 11429 просмотров
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Barvinok писал(а):
Чт фев 11, 2021 2:40 pm
После обновления вылезла ошибка "Недостаточно памяти, напишите gpu_mem=128".
config.txt на SD карте свой, не тот что записал конфигуратор?

Сломался от второго экрана. Сейчас будет новая версия.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Родной, конфигураторный. Ничего не менял, только добавил gpu_mem=128
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

В родном конфигураторном должно было быть "gpu_mem=96", моей малине этого на два экрана по 1920x1080 хватало. Любопытно, почему твоя ругалась.

Выложил 6.0.36. Попробуй пожалуйста на двух экранах.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Всё одно затребовал gpu_mem=128.
После внесения - работает.
Вложения
WTware v.6.0.36_RPi.html
(43.88 КБ) 119 скачиваний
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

aka писал(а):
Чт фев 11, 2021 9:55 pm
В родном конфигураторном должно было быть "gpu_mem=96"
Я такого не видел.
Обновляю через браузер.

Пошла обратная связь от пользователей.
Переключения окон приложений (Alt+Tab или просто мышкой) или скрол происходят не гладко. Сначала секунду все окна в размыты (как в пикселях), потом чётко.
Видео отправлю письмом.
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Barvinok писал(а):
Пт фев 12, 2021 11:53 am
aka писал(а):
Чт фев 11, 2021 9:55 pm
В родном конфигураторном должно было быть "gpu_mem=96"
Обновляю через браузер.
Понял. Обновление не меняет конфиги, меняются только бинарные файлы. config.txt остался старый.
Barvinok писал(а):
Пт фев 12, 2021 11:53 am
Сначала секунду все окна в размыты (как в пикселях), потом чётко.
Видео отправлю письмом.
Не вижу на этом видео "потом четко". Все размыто.

По идее так и задумано, кодек быстро кидает черновую картинку и понемногу уточняет. Люди ругаются?
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

Перестал работать VLC, на версии 5.8.32 работает на версии 6.0.34 показывает первый кадр и зависает, конкретно пытался выводить видео с камеры в конфиге такие настройки :

clienthostname=StafOfice_QUEUE
video=intel(U)
display=1920x1080, VGA
infobox=always, shutdown, reboot
user= список пользователей; --new--
M2_display=1280x720, HDMI
connection
next screen
connection
next screen
connection
M2_next screen
connection
application=vlc
vlc_cmdline=rtsp://192.168.2.38:7447/bfb6a216-61d2-31e4-8bfe-744b38d1ae81_0
M2_next screen
connection
server= сервер для подключения
user= один пользователь с паролем для автоподключения
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Попробуй video=modesetting(U).
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

aka писал(а):
Пт фев 12, 2021 1:53 pm
Не вижу на этом видео "потом четко". Все размыто.
По идее так и задумано, кодек быстро кидает черновую картинку и понемногу уточняет. Люди ругаются?
Снято на телефон, но люди сильно ругались.
На обычном кодеке же всё хорошо, почему h264 так не умеет?
Пришлось его выключить :(
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

aka писал(а):
Пт фев 12, 2021 5:04 pm
Попробуй video=modesetting(U).
Попробовал, не помогло, всё одно терминал наглухо зависает , при чём зависает вначале экран с VLC, а уже потом экран с выбором юзеров,
в понедельник попробую новую версию отпишусь...
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

А вообще нужно всё же как то сообщать, что в новой версии "трогалось", изменялось и добавлялось, не нужно прям расписывать, достаточно по блокам функциональности история тоже не нужна достаточно начать с любой версии....
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

KudrC писал(а):
Пт фев 12, 2021 6:38 pm
в понедельник попробую новую версию отпишусь...
Лог покажи.
KudrC писал(а):
Пт фев 12, 2021 6:39 pm
А вообще нужно всё же как то сообщать, что в новой версии "трогалось", изменялось и добавлялось
Между 6.0.34 и 6.0.36 обновилось линуксовое ядро. Всего на единичку, ничего глобального, рутинное поддержание актуальной версии ядра, ядер в втвари три разных (x86, UEFI, малина), все три постоянно обновляются. Changelog одного только ядра, обновившегося на одну только единичку - больше двух тысяч строк: https://cdn.kernel.org/pub/linux/kernel ... Log-5.4.97

Расскажи, что ты станешь делать с этой информацией?
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Barvinok писал(а):
Пт фев 12, 2021 6:32 pm
Снято на телефон, но люди сильно ругались.
На обычном кодеке же всё хорошо, почему h264 так не умеет?
Лог покажи. С той малины, на которой особенно заметно. Ещё хорошо бы проверить, что у неё со скоростью сети (например, заливанием большого файла НА флешку в малине) и что с загрузкой процессора сервера.

У меня даже на третьей малине переключение окошек мновенное, никакой ступенчатой прорисовки не видно.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

h264 более требователен к сети?
Вообще там гигабитная сеть, но большинство подключены транзитом через ip-телефоны и со 100 Мбитным свичём.
На сервере 32 ядра, загрузка ~15%.
Я проверю в понедельник как будет при прямом подключении и пришлю лог.
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

На третьей малине 100 мегабит, внутри подключенные по USB. Этого хватает, чтобы я никакого промежуточного состояния окошка не видел. Но это должны быть работающие 100 мегабит. Потому и предлагаю проверить записью на флешку, сколько на самом деле доходит до терминала.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Сегодня проверил работу сети. Прокачивал образ раздела, снятый Акронисом (tib) размером ~120GB (не целиком, минут пять).
Гигабитный свич и две гигабитные сетевушки (сервер-ноутбук) напрямую выдают 80-90МБайт/сек.
Через ip-телефон (100Мбит) - 8-9МБайт/с.
Без потерь. Без ошибок.
При работе за терминалом с включённым H264 и так и эдак я вижу размытость и при скроле и переключениях между окнами. На всех малинах так, не на одной. Примерно пол секунды.
Это действительно напрягает глаза.
С кодеком GFX такого не происходит.
Вложения
2021-02-15_23-59-47.png
2021-02-15_23-59-47.png (43.6 КБ) 11244 просмотра
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

aka писал(а):
Пт фев 12, 2021 8:29 pm
KudrC писал(а):
Пт фев 12, 2021 6:38 pm
в понедельник попробую новую версию отпишусь...
Лог покажи.
KudrC писал(а):
Пт фев 12, 2021 6:39 pm
А вообще нужно всё же как то сообщать, что в новой версии "трогалось", изменялось и добавлялось
Между 6.0.34 и 6.0.36 обновилось линуксовое ядро. Всего на единичку, ничего глобального, рутинное поддержание актуальной версии ядра, ядер в втвари три разных (x86, UEFI, малина), все три постоянно обновляются. Changelog одного только ядра, обновившегося на одну только единичку - больше двух тысяч строк: https://cdn.kernel.org/pub/linux/kernel ... Log-5.4.97

Расскажи, что ты станешь делать с этой информацией?
Уважаемый Ака, я конечно понимаю иронию и считаю себя обыкновенным юзером (потому к стати и пользуюсь вашим продуктом, так как всё относительно просто для меня), но конкретно информация о том, что поменялась линуксовое ядро, для меня говорит о том , что есть смысл проверить старые хотелки которые не работали или работали коряво на предыдущей версии, а если бы было написано, что изменилась версия VLC, то я бы попробовал немного другую конфигу для мозайки, а если написано будет, что поменялся загрузчик для "малинки", то я ничего делать не буду, так как не использую малинки.... как то так.
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

KudrC писал(а):
Пт фев 12, 2021 4:48 pm
Перестал работать VLC, на версии 5.8.32 работает на версии 6.0.34 показывает первый кадр и зависает, конкретно пытался выводить видео с камеры в конфиге такие настройки :

clienthostname=StafOfice_QUEUE
video=intel(U)
display=1920x1080, VGA
infobox=always, shutdown, reboot
user= список пользователей; --new--
M2_display=1280x720, HDMI
connection
next screen
connection
next screen
connection
M2_next screen
connection
application=vlc
vlc_cmdline=rtsp://192.168.2.38:7447/bfb6a216-61d2-31e4-8bfe-744b38d1ae81_0
M2_next screen
connection
server= сервер для подключения
user= один пользователь с паролем для автоподключения

Попробовал версию WTware v.6.0.36, та жа история показывает на втором экране первый кадр с камеры и зависает,
пробовал и с параметром
video = modesetting(U) , всё одно зависает
Вложения
WTware v.6.0.36.zip
(59.36 КБ) 119 скачиваний
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

KudrC писал(а):
Вт фев 16, 2021 5:21 pm
Попробовал версию WTware v.6.0.36, та жа история показывает на втором экране первый кадр с камеры и зависает
Попробуй это: http://wtware.com/testing/202102210527.zip
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

ага, понял сегодня проверю.
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

так заработало, в смысле не зависает и экран с VLC отображает видео, спасибо за оперативность.
Пока будут работать на данной версии (6.0.37), если будут проблемы отпишусь.
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

так следующие отзывы о работе 6.0.37 :
конфиг
clienthostname=StafOfice_QUEUE
video=modesetting(U)
display=1600x900; VGA
disk=usb
infobox=always, shutdown, reboot
M2_display=1280x720; HDMI
M2_position=right-top
connection
next screen
connection
next screen
connection
M2_next screen
connection
application=vlc
vlc_cmdline=rtsp://192.168.2.38:7447/bfb6a216-61d2-31e4-8bfe-744b38d1ae81_0
M2_next screen
connection
server=192.168.2.116
user=ochered_MAD[VIDEO QUEUE (очередь)]:\x6a\x78\x74\x68\x74\x6c\x6d\x32\x30\x31\x21


1. ОЧЕНЬ медленное переключение экранов на первом мониторе (прям видно как один "переползает" во второй), на втором вроде как быстро
2. ОЧЕНЬ медленная реакция на нажатие (выбор пользователя) на первом экране
3. Работа в самомой терминальной сессии вроде нормальная (юзеры не жалуются)
Вложения
wtware_6.0.37_192_168_2_165.txt.zip
(28.68 КБ) 110 скачиваний
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

KudrC писал(а):
Пн фев 22, 2021 12:05 pm
1. ОЧЕНЬ медленное переключение экранов на первом мониторе (прям видно как один "переползает" во второй), на втором вроде как быстро
Напиши в конфиг:

Код: Выделить всё

animation_speed = 0
На втором мониторе переключение из VLC в RDP должно быть мгновенным. Из RDP и VLC медленно потому что VLC запускается.

KudrC писал(а):
Пн фев 22, 2021 12:05 pm
2. ОЧЕНЬ медленная реакция на нажатие (выбор пользователя) на первом экране
Этого не понимаю. Опиши подробнее.
Если убрать из конфига второй монитор, починится?
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Очередной отклик пользователя на новый кодек:
Привет, вот такая проблема появилась, неделю не включал комп, вернулся в какай бы программе или странице не находился везде после прокрутки картинка очень плохого качества потом восстанавливается, с чем может быть связано? [...] Прям глаза режет.
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

aka писал(а):
Пн фев 22, 2021 11:33 pm
KudrC писал(а):
Пн фев 22, 2021 12:05 pm
1. ОЧЕНЬ медленное переключение экранов на первом мониторе (прям видно как один "переползает" во второй), на втором вроде как быстро
Напиши в конфиг:

Код: Выделить всё

animation_speed = 0
На втором мониторе переключение из VLC в RDP должно быть мгновенным. Из RDP и VLC медленно потому что VLC запускается.
KudrC писал(а):
Пн фев 22, 2021 12:05 pm
2. ОЧЕНЬ медленная реакция на нажатие (выбор пользователя) на первом экране
Этого не понимаю. Опиши подробнее.
Если убрать из конфига второй монитор, починится?
Установил animation_speed = 0 и всё заработало как и раньше , второй монитор не убирал,
странно что на версии 5.Х этот параметр работал по другому (так медленно не менял экраны).
пункт 2 тоже вылечился (было - мышкой кликаешь по элементу из списка пользователей и фокус на "выбранного" пользователя переходил с задержкой)
Насчёт переключений из RDP на VLC всё правильно переключается, я знаю , что VLC при этом стартует (и это правильно мне так и надо)
в общем animation_speed = 0 помогло, других претензий от пользователей не отмечено.
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Barvinok писал(а):
Ср фев 24, 2021 10:05 am
...после прокрутки картинка очень плохого качества потом восстанавливается, с чем может быть связано?
Если написать ему в конфиг "graphic=disable-h264", станет лучше? Или будет как с бородой под/над одеялом?
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

KudrC писал(а):
Ср фев 24, 2021 4:45 pm
Установил animation_speed = 0 и всё заработало как и раньше , второй монитор не убирал,
странно что на версии 5.Х этот параметр работал по другому (так медленно не менял экраны).
Странно. Много лет ничего в этом сдвиге не менялось. Попробуй тест скорости графики, который из меню по Del вызывается. В 5.Х и в свежей, и сравнить результаты. А то VLC в логе ругалось, что очень медленно прорисовалось, и анимация замедлилась, может что-о со скоростью рисования хуже стало.
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

aka писал(а):
Ср фев 24, 2021 5:36 pm
Barvinok писал(а):
Ср фев 24, 2021 10:05 am
...после прокрутки картинка очень плохого качества потом восстанавливается, с чем может быть связано?
Если написать ему в конфиг "graphic=disable-h264", станет лучше? Или будет как с бородой под/над одеялом?
Отклики пользователей, когда выключил h264 (сначала некоторым в конфиге, а потом целиком на сервере):
Оооо, кайф) визуальный экстаз) спасибо!!
Во, гораздо лучше, спасибо
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

aka писал(а):
Ср фев 24, 2021 5:40 pm
KudrC писал(а):
Ср фев 24, 2021 4:45 pm
Установил animation_speed = 0 и всё заработало как и раньше , второй монитор не убирал,
странно что на версии 5.Х этот параметр работал по другому (так медленно не менял экраны).
Странно. Много лет ничего в этом сдвиге не менялось. Попробуй тест скорости графики, который из меню по Del вызывается. В 5.Х и в свежей, и сравнить результаты. А то VLC в логе ругалось, что очень медленно прорисовалось, и анимация замедлилась, может что-о со скоростью рисования хуже стало.
Вот результаты измерений:
WTware 5.8.32
intel(U) - 17,70
modesetting(U) - 27,85

WTware 6.0.37
intel(U) - 82,73
modesetting(U) - 164.85

и ещё такое прилетело от пользователей WTware 6.0.37 - "интернет тупит" , от пользователей WTware 5.8.32 жалобна подобное нет, хотя все работают на одном терминальном сервере, после того как я их попытал вроде как выяснилось, что хром запущенный в терминальной сессии медленно перерисовывает странички электронной почты.
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение aka »

Цифры адские же. Что-то сломалось. Покажи два одинаковых лога от 5.8.32 и от 6.0.37. Чтобы конфиг одинаковый, железо одинаковое, только версии втвари разные.
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

aka писал(а):
Пн мар 01, 2021 8:13 pm
Цифры адские же. Что-то сломалось. Покажи два одинаковых лога от 5.8.32 и от 6.0.37. Чтобы конфиг одинаковый, железо одинаковое, только версии втвари разные.
логи как заказывал
Вложения
WTware_v.6.0.37.txt
(134.23 КБ) 119 скачиваний
WTware_5.8.32.txt
(142.88 КБ) 123 скачивания
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34-6.0.38 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение aka »

В версии 6.0.38 переписан h264 на малине и сделан h264 на x86 32- и 64-битных. На Intel должна заработать аппаратная акселерация.
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34-6.0.38 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение aka »

KudrC
Для матери есть BIOS на два года новее. Случалось, что новый биос чинил проблемы: https://downloadcenter.intel.com/downlo ... -TYBYT10H-

Других мыслей нет :( В логе всё выглядит хорошо. Не понимаю, почему скорость рисования так упала. На этой машине загрузку по UEFI в биосе нельзя включить?
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34-6.0.38 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение KudrC »

aka писал(а):
Пт апр 02, 2021 1:58 am
KudrC
Для матери есть BIOS на два года новее. Случалось, что новый биос чинил проблемы: https://downloadcenter.intel.com/downlo ... -TYBYT10H-

Других мыслей нет :( В логе всё выглядит хорошо. Не понимаю, почему скорость рисования так упала. На этой машине загрузку по UEFI в биосе нельзя включить?
Ок, спасибо за подсказку, попробую поиграться с новой версией и прошивками, о результатах сообщу.
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34-6.0.40 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение aka »

KudrC
Через час 6.0.40 выложится. Там ещё один костылик в ядре поменяется, врядли, но вдруг...
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение Barvinok »

Barvinok писал(а):
Пн фев 15, 2021 11:52 pm
При работе за терминалом с включённым H264 и так и эдак я вижу размытость и при скроле и переключениях между окнами. На всех малинах так, не на одной. Примерно пол секунды.
Это действительно напрягает глаза.
С кодеком GFX такого не происходит.
В последних версиях - всё хорошо!
Говорят, даже гораздо лучше, чем с GFX!
Barvinok
Сообщения: 513
Зарегистрирован: Вт ноя 30, 2004 4:06 pm
Откуда: Ростов-на-Дону
Контактная информация:

Re: 6.0.34-6.0.42 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение Barvinok »

Всё хорошо, кроме RPi4 с двумя мониторами.
Через несколько минут работы замирает картинка. Без артефактов. Мышь бегает. Терминал работает - запросто вхожу на web или подключаюсь по VNC. Всё быстро, не тупит.
Сеанс работает - можно зайти с другого терминала или с винды.
На Pi4 тут же появляется сообщение, дескать, кто-то вошёл в сеанс.
Можно снова зайти - сразу покажет замёрзший рабочий стол.
Если выключить h264 - не виснет.
Два лога во время такого фриза прилагаю
Вложения
WTware v.6.0.46_RPi_1.html
(59.18 КБ) 74 скачивания
WTware v.6.0.46_RPi.html
(47.89 КБ) 79 скачиваний
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34 - аппаратное ускорение h264 на Raspberry

Сообщение KudrC »

KudrC писал(а):
Пн мар 01, 2021 6:59 pm
aka писал(а):
Ср фев 24, 2021 5:40 pm
KudrC писал(а):
Ср фев 24, 2021 4:45 pm
Установил animation_speed = 0 и всё заработало как и раньше , второй монитор не убирал,
странно что на версии 5.Х этот параметр работал по другому (так медленно не менял экраны).
Странно. Много лет ничего в этом сдвиге не менялось. Попробуй тест скорости графики, который из меню по Del вызывается. В 5.Х и в свежей, и сравнить результаты. А то VLC в логе ругалось, что очень медленно прорисовалось, и анимация замедлилась, может что-о со скоростью рисования хуже стало.
Вот результаты измерений:
WTware 5.8.32
intel(U) - 17,70
modesetting(U) - 27,85

WTware 6.0.37
intel(U) - 82,73
modesetting(U) - 164.85

и ещё такое прилетело от пользователей WTware 6.0.37 - "интернет тупит" , от пользователей WTware 5.8.32 жалобна подобное нет, хотя все работают на одном терминальном сервере, после того как я их попытал вроде как выяснилось, что хром запущенный в терминальной сессии медленно перерисовывает странички электронной почты.
Прошу прощение за долгое отсутствие, то железяка ломалась, то дел не впроворот, то митинги, короче пока не закрыли продолжаю тестирование:
по моему мало что поменялось, железяка та же и конфиг тот же
WTware 6.0.46
intel(U) - 84,62
modesetting(U) - 165.74
KudrC
Сообщения: 56
Зарегистрирован: Чт ноя 08, 2018 9:02 pm

Re: 6.0.34-6.0.38 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение KudrC »

aka писал(а):
Пт апр 02, 2021 1:58 am
KudrC
Для матери есть BIOS на два года новее. Случалось, что новый биос чинил проблемы: https://downloadcenter.intel.com/downlo ... -TYBYT10H-

Других мыслей нет :( В логе всё выглядит хорошо. Не понимаю, почему скорость рисования так упала. На этой машине загрузку по UEFI в биосе нельзя включить?
Насчёт BIOS и UEFI пока не менял, но планирую, как сделаю отпишусь о результатах
aka
Разработчик
Разработчик
Сообщения: 10976
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 6.0.34-6.0.42 - аппаратное ускорение h264 на Raspberry и Intel

Сообщение aka »

Barvinok писал(а):
Пт апр 09, 2021 3:22 pm
Всё хорошо, кроме RPi4 с двумя мониторами.
Нашел ошибку у RPi4 с двумя мониторами и h264. Должно исправиться в 6.0.52.
Ответить