5.4.44 Tonk 1202

Свойства, ошибки, замечания и проблемы определенных версий WTware
Ответить
vicyn
Сообщения: 38
Зарегистрирован: Пн дек 16, 2013 9:48 am

5.4.44 Tonk 1202

Сообщение vicyn » Пн сен 05, 2016 2:22 pm

Добрый день, используем в организации Tonk 1202, на последней версии wtware загрузка с ними не проходит.
Конфигурация клиента следующая

Код: Выделить всё

video=lxfb(F)
refresh=60
resolution=1280x720
bpp=16
graphic=adg
clienthostname=client_name
server=server_name
domain=domain_name
loadbalanceinfo=tsv://terminalserver
user=user
disk=usb
vnc=on
ask_password=on
connection
Во вложении фото на чем зависает загрузка.
Подскажите как решить проблему?
Вложения
IMG_20160905_161020.jpg
Скрин загрузки
IMG_20160905_161020.jpg (104.77 КБ) 2638 просмотров

aka
Разработчик
Разработчик
Сообщения: 9563
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.4.44 Tonk 1202

Сообщение aka » Пн сен 05, 2016 7:04 pm

До конфига втвари дело не доходит, встаёт раньше.

Что написано в 067 параметре DHCP?

Если DHCP выключить, картинка на экране на что сменится?

И ещё один тест:
1. Найти тот файл, который указан в 067 параметре DHCP.
2. Удалить. Или спрятать в бэкап, но чтобы в каталоге 5.4.44 его больше не было.
3. Перегрузить машину. Убедиться, что ошибка сменится на File not found.
4. Найти файл с тем же именем из более старой втвари и записать в каталог 5.4.44.

Заработает?

Rushmore
Сообщения: 358
Зарегистрирован: Пн фев 11, 2013 9:36 pm

Re: 5.4.44 Tonk 1202

Сообщение Rushmore » Пн сен 05, 2016 10:58 pm

Есть у меня пара машинок, которые зависали в свежих версиях iPXE похожим образом. Обновление BIOS исправило ситуацию.

vicyn
Сообщения: 38
Зарегистрирован: Пн дек 16, 2013 9:48 am

Re: 5.4.44 Tonk 1202

Сообщение vicyn » Вт сен 06, 2016 10:37 am

В 067 стоит сейчас "5.2.32/wtware.http", для теста прошивки 5.4.44 делали "5.4.44/wtware.http".
При отключении dhcp загружается прошивка клиента, т.е ничего не происходит.
Делали тест с удалением wtware.http из папки 5.4.44, при загрузке было File not found, потом поменяли его на файл из 5.2.32 - загрузка в этом случае прошла но не до конца, после загрузке было черное окно с надписью "press any key to reboot".
С обновлением биоса вариант не прошел - стоит актуальная версия биоса, на сайте производителя свежее ничего нет.

aka
Разработчик
Разработчик
Сообщения: 9563
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.4.44 Tonk 1202

Сообщение aka » Вт сен 06, 2016 1:26 pm

Подтверждаю проблему с wtware.http на старых (очень старых! с процессорами классом ниже первого пентиума!) машинах. Например, такое вот нашёл:
It therefore seems reasonable to assume that
SSE will be supported on any hardware that might realistically be used
with new iPXE builds.

As a side benefit of this change, the MMX register %mm0 will now be
preserved across virt_call() even in an i386 build of iPXE...
Аффторы iPXE (который в втвари лежит в wtware.http) пишут, что будут использовать SSE команды (этих команд нет в древних процессорах) даже если собирается для i386. Я пытался собрать свежий iPXE для i386, и оно у меня тоже не взлетало на машинах с древними процессорами AMD Geode.

Как обойти проблему:

1. Не использовать HTTP загрузку на таком антиквариате. Обычная PXE загрузка будет работать.
2. Взять wtware.http из старых втварей: http://wtware.com/files/wtware.http.2015.oldPCs.zip и положить в каталог к свежей версии. Оно тоже должно работать.

vicyn писал(а):..тест с удалением wtware.http из папки 5.4.44, при загрузке было File not found, потом поменяли его на файл из 5.2.32 - загрузка в этом случае прошла но не до конца, после загрузке было черное окно с надписью "press any key to reboot".
С обновлением биоса вариант не прошел - стоит актуальная версия биоса, на сайте производителя свежее ничего нет.
Возьми wtware.http из архива по ссылке выше. Если с ним не поедет, покажи фотки.

vicyn
Сообщения: 38
Зарегистрирован: Пн дек 16, 2013 9:48 am

Re: 5.4.44 Tonk 1202

Сообщение vicyn » Чт сен 08, 2016 2:41 pm

увы не поехало, та же ситуация, загружается но потом на экране press a key to reboot, скрин прилагаю (прошу прощение за качество)
IMG_20160908_160122.png
IMG_20160908_160122.png (251.92 КБ) 2597 просмотров
Последний раз редактировалось vicyn Чт сен 08, 2016 2:46 pm, всего редактировалось 1 раз.

aka
Разработчик
Разработчик
Сообщения: 9563
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.4.44 Tonk 1202

Сообщение aka » Чт сен 08, 2016 2:41 pm

Не вижу скрин.

vicyn
Сообщения: 38
Зарегистрирован: Пн дек 16, 2013 9:48 am

Re: 5.4.44 Tonk 1202

Сообщение vicyn » Пт сен 09, 2016 6:14 am

а это и есть скрин, т.е прошивка сначало загружается нормально без ошибок и зависаний, но далее вместо окна с предложением ввести пароль пользователя такое
IMG_20160908_160122.png
IMG_20160908_160122.png (251.92 КБ) 2583 просмотра

aka
Разработчик
Разработчик
Сообщения: 9563
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: 5.4.44 Tonk 1202

Сообщение aka » Пт сен 09, 2016 11:44 am

Не кредставляю, кто это пишет. Фотку предыдущего экрана, перед этим "PRESS A KEY" можешь успеть сделать?

Открой в текстовом редакторе wtware.http.cfg и убери там слово quiet. Что изменится?

Обычная PXE загрузка работает? Если в 067 DHCP написать "5.4.44/wtware.pxe".

Ответить