В версии 5.4.40 при загрузке с CD не подгружается конфиг и лицензии

Свойства, ошибки, замечания и проблемы определенных версий WTware
Ответить
James123
Сообщения: 42
Зарегистрирован: Ср авг 06, 2014 1:56 pm

В версии 5.4.40 при загрузке с CD не подгружается конфиг и лицензии

Сообщение James123 » Пн авг 15, 2016 10:16 am

Подобная ошибка уже была на 5.4.14. Все параметры загрузки настроены по DHCP. На CD ничего, кроме загрузчика, не записываю, ни конфиги, ни лицензии. Лог прилагаю.
Вложения
No_conf&lic.zip
(13.53 КБ) 77 скачиваний

aka
Разработчик
Разработчик
Сообщения: 9783
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: В версии 5.4.40 при загрузке с CD не подгружается конфиг и лицензии

Сообщение aka » Пн авг 15, 2016 10:24 pm

Вижу в логе:

/--- FILE "/bootmedia/configs/initrd.wtc" -----------------------
| clientIP = *
| config = local
\----------------------------------------------------

Это означает "брать конфиг с CD".

И вижу в логе записанный на CD конфиг. Без лицензии.

Последняя установленная втварь была 5.4.40? Не могло быть такого, что поверх 5.4.40 была установлена старая 5.4.14? Если надо поставить старую версию, её можно ставить поверх, но после установки старой надо ЕЩЁ РАЗ поставить поверх свежую версию. Чтоб конфигуратор был от свежий, не старый.

Попробуй переделать образ CD и заскриншоть, что радиобатон в "конфигаруции терминала" стоит в "скачать с TFTP".

James123
Сообщения: 42
Зарегистрирован: Ср авг 06, 2014 1:56 pm

Re: В версии 5.4.40 при загрузке с CD не подгружается конфиг и лицензии

Сообщение James123 » Вт авг 16, 2016 10:58 am

Что-то я не понял... Причем здесь установка старой поверх новой? Мы регулярно обновляем версию WtWare с сайта, всё время переходим на более новую. Сейчас стоит 5.4.40.
Просто ТОЧНО такая же ошибка, когда на CD записывался такой конфиг, типа "брать всё с CD" была и в 5.4.14 (вот ветка форума http://forum.wtware.ru/viewtopic.php?f=10&t=19602). Я ничего не настраиваю в конфигураторе при создании CD, все значения стоят по умолчанию. Если берем диск любой другой версии, кроме 5.4.40, всё нормально подгружается с сервера.
Скриншот какие настройки указываются при создании загрузочного CD добавил.
Вложения
Image 1.png
Image 1.png (66.26 КБ) 2017 просмотров

aka
Разработчик
Разработчик
Сообщения: 9783
Зарегистрирован: Ср окт 01, 2003 12:06 am
Откуда: Роcсия, Тольятти
Контактная информация:

Re: В версии 5.4.40 при загрузке с CD не подгружается конфиг и лицензии

Сообщение aka » Вт авг 16, 2016 11:42 am

CD писал новый, не дописывал старый?

Я помню такую проблему. Её починили. Поэтому я и спрашиваю, не осталось ли чего-то от старой версии, когда проблема ещё была. Конфигуратор от 5.4.40 у меня делает правильный образ.

Far умеет входить внутрь iso файлов. WinRAR умеет просматривать содержимое iso файлов. Попробуй сделать образ с настройками как на скриншоте и не записывать на диск, а открыть свежесделанный образ. И посмотри, что написано в файле CONFIGS\INITRD.WTC Должно быть так:

Код: Выделить всё

clientIP = *
config = network

James123
Сообщения: 42
Зарегистрирован: Ср авг 06, 2014 1:56 pm

Re: В версии 5.4.40 при загрузке с CD не подгружается конфиг и лицензии

Сообщение James123 » Вт авг 16, 2016 11:54 am

Диски всегда пишем новые, старые просто выбрасываем.
Я смотрел файл initrd.wtc. В той версии, что не хотел грузить написан local. Сейчас пересоздал новый диск - написано network. То ли я пьяный был и щелкнул "Конфигурация писать на CD", то ли инопланетяне подменили диск.
Извини за панику и спасибо за оперативность.

Ответить